19-06-2009 ДубльГИС-Плагин: «АвтоГРАФ-2GIS - плеер треков» v.1.1 - ТехноКом - разработка и производство электроники, системы спутникового мониторинга GPS, бытовая электроника, промышленная автоматизация

ДубльГИС-Плагин: «АвтоГРАФ-2GIS - плеер треков»

Компания «ТехноКом» выпустила модуль расширения для ПО «АвтоГРАФ»: ДубльГИС-Плагин: «АвтоГРАФ-2GIS - плеер треков».
Модуль расширения представляет из себя бесплатный, свободно распространяемый плагин для известной бесплатной электронной карты-справочника «ДубльГИС для ПК» (www.2gis.ru). Плагин полностью встраивается в интерфейс программы «ДубльГИС для ПК» и обеспечивает функции, аналогичные плееру треков ПО «АвтоГРАФ» на карте ДубльГИС:
– отображение трека заданного ТС за выбранный период
– отображение ТС на треке
– отображение всех ТС группы на карте города
– проигрывание движения ТС по треку в заданном масштабе времени
– отображение контрольных точек на карте
– отображение списков событий: остановок, срабатываний датчиков, потерь сигнала GPS, превышений скоростного режима, заправок и сливов топлива, пропаданий питания и т.п. на вкладке плагина
– отображение значков событий, перечисленных выше, на карте города
– выбор ТС и периода отображения на вкладке плагина (без необходимости переключения в ПО «АвтоГРАФ»)
На текущий момент, система «ДубльГИС для ПК» обеспечивает поддержку карт для следующих городов: Астрахань, Барнаул, Бийск, Екатеринбург, Иркутск, Казань, Кемерово, Красноярск, Курган, Нижневартовск, Нижний Новгород, Новокузнецк, Новосибирск, Одесса, Омск, Пермь, Самара, Тольятти, Томск, Тюмень, Уфа, Челябинск. В будущем, список городов будет расширяться.
Уважаемые пользователи системы «АвтоГРАФ» и гости сайта: посмотреть работу плагина в реальных условиях можно, скачав демо-версию ПО «АвтоГРАФ» и установив «ДубльГИС для ПК» с картой г. Челябинска.
Описание процедуры установки, настройки и работы с плагином - см. ниже...
Загрузить плагин «АвтоГРАФ-2GIS - плеер треков» Вы можете в нашем файловом архиве >>>

Системные требования:
– Операционная система: Microsoft Windows 2000, Microsoft Windows XP, Microsoft Windows Vista, Microsoft Windows 7
– ДубльГИС 3.0: оболочка версии 3.0.5.3 и выше (www.2gis.ru) – распространяется бесплатно
– Карты городов (www.2gis.ru) – распространяются бесплатно
– ПО «АвтоГРАФ» v.2.20.0 и выше (файловый архив)
– Плагин «АвтоГРАФ-2GIS - плеер треков» (файловый архив)

Процедура установки плагина:
Для установки плагина «АвтоГРАФ-2GIS - плеер треков», необходимо:
1. Установить ДубльГИС 3.0 v.3.0.5.3 или выше
2. Установить требуемые карты городов
3. Установить ПО «АвтоГРАФ» и хотя бы 1 раз запустить его для регистрации в системе
4. Скачать архив с плагином «АвтоГРАФ-2GIS - плеер треков» из файлового архива
5. Распаковать файлы (AGSettings.xml, AGPlayerPlugin.dll, AGPlayerPlugin.dgxpi) из этого архива в каталог Plugins программы ДубльГИС 3.0 (по умолчанию - C:\Program Files\2gis\3.0\Plugins\)
6. Запустите ДубльГИС 3.0
7. Выберите вкладку «АвтоГРАФ» в панели «Справочники» (в левой части окна ДубльГИС) при этом автоматически загрузится ПО «АвтоГРАФ» (если оно не было открыто). Плагин готов к работе.

Возможные ошибки и способы их устранения:

Ошибка: При выборе вкладки «АвтоГРАФ» в панели «Справочники» (в левой части окна ДубльГИС) на экране возникает уведомление об ошибке запуска ПО «АвтоГРАФ» или регистрации класса.
или

Возможная причина:
– ПО «АвтоГРАФ» не установлено или ни разу не запускалось из папки, где оно находится.
– Ошибка регистрации ПО «АвтоГРАФ» в системе (ошибка регистрации СОМ-объекта)

Решение:
1. Установите (если требуется) и запустите ПО «АвтоГРАФ» для его регистрации в системе.
2. Если п.1. не помогает - запустите файл AG_OLE_UNREG.REG из архива с плагином (требуются права Администратора), после чего повторите п.1.
3. Если ошибка не исчезает - обратитесь в компанию «ТехноКом» или к ближайшему представителю.

Работа с плагином

Окно карты:

Окно плагина:

Выбор периода:

Выбор периода определяет временной интервал, на котором будет производиться просмотр треков и рейсов выбранного ТС. Разбиение на рейсы внутри выбранного периода производится согласно правилам, определенным для данного ТС в ПО «АвтоГРАФ».

Выбор ТС:
Эта группа полей служит для выбора групп и ТС. Поля соответствуют полям списка транспорта в ПО «АвтоГРАФ».
– Если выбрана ТОЛЬКО группа ТС, то на карте будет отображаться значками текущее местоположение всех машин выбранной группы.
– Если выбрано конкретное ТС, то на карте будет отображаться трек этого ТС, а также его контрольные точки и события.
В поле «№ рейса» отображается номер текущего рейса для выбранного ТС.

Информационные точки:

Информационные точки служат для просмотра информации по выбранному ТС:
– Список рейсов
– Посещение контрольных точек
– Список остановок
– Периоды отсутствия сигнала со спутника
– Периоды пропадания питания
– Периоды превышения скорости
– Заправки и сливы топлива
– Срабатывания датчиков
Щелчок на строке таблицы вызывает перемещение курсора в точку трека, в которой наступило выбранное событие.
Поле «Продолжительность от, с» задает минимальную продолжительность события в секундах. Это необходимо для того, чтобы, например, отбросить очень кратковременные превышения скорости, остановки малой продолжительности (например - отсеять остановки на светофорах) или сработки датчиков, которые могут быть вызваны тряской или дребезгом контактов.
Список информационных точек может настраиваться с помощью кнопки:

Отметьте галочками требуемые виды информационных точек и нажмите кнопку «ОК».

Управление плеером треков:

Эта панель служит для управления плеером треков, запуска и остановки воспроизведения, управления отображением трека, значков событий, регулировки скорости воспроизведения и т.п.

Функции кнопок:

(воспроизведение) – запуск воспроизведения движения ТС по треку. Во время движения ТС по треку, вид кнопки воспроизведения изменяется на [image] (пауза).
(пауза) – служит для приостановки воспроизведения. Для возобновления воспроизведения, снова нажмите кнопку [image].
(стоп) – служит для полной остановки воспроизведения и возврата на начало трека.
(отображение трека) – служит для включения / выключения отображения трека на карте.
(отображение КТ) – служит для включения / выключения отображения контрольных точек на карте. Контрольные точки отображаются на карте в виде заштрихованных окружностей, соответствующего радиуса. Координаты, радиус и названия КТ задаются в ПО «АвтоГРАФ».
(отображение всех информационных точек) – служит для включения / выключения отображения всех информационных точек на карте.
(выбор типов отображаемых информационных точек) – [image] [image] – служит для включения / выключения отображения на карте отдельных типов информационных точек. При этом, становится доступным следующий диалог выбора:

Вид значков информационных точек (слева) идентичен значкам, которыми обозначены эти точки на карте.

(пропуск остановок) – служит для включения / выключения режима пропуска остановок при воспроизведении движения ТС по треку.
– При выключенном режиме пропуска остановок, ТС будет находиться в точке остановки в течение времени, пропорциональном скорости воспроизведения трека (масштабу времени) и длительности остановки.
– При включенном режиме пропуска остановок, ТС будет находиться (замирать) в точке остановки в течение 1 секунды, вне зависимости от длительности остановки.
(настройка списка информационных точек) – см. «Информационные точки».

(скорость воспроизведения) – задает коэффициент временного масштаба для воспроизведения трека. Т.е. во сколько раз быстрее будет движение курсора по треку, чем это происходило в реальности. Доступны для выбора следующие значения коэффициента: 1х, 3х, 6х, 10х, 30х, 60х, 100х, 300х, 600х. Кроме того, Вы можете вручную ввести в поле ввода нужный Вам коэффициент.

(полоса прокрутки трека) – служит для перемещения по треку.

Информационная панель:

Информационная панель служит для отображения текущих значений параметров ТС во время его движения по треку:
– Дата и точное время текущей точки трека
– Скорость ТС в текущей точке трека
– Пробег в метрах от начала трека до текущей точки трека

На этом обзор работы с плагином можно считать законченным...
Примечание: ТС – транспортное средство.

Все пожелания, замечания, предложения, замеченные ошибки и т.п. просим сообщать, присылать и обсуждать на информационных ресурсах компании «ТехноКом»:

  • Официальный форум: http://board.tk-chel.ru
  • E-mail (общий ящик): mail@tk-chel.ru
  • E-mail (личный ящик автора плагина): storm@tk-chel.ru